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Preface 
This document provides guidance on how to make PDF documents accessible to people with disabilities. 

The document is based on the latest version of the Web Content Accessibility Guidelines (WCAG), 

specifically WCAG 2.2, which are the international standards for web accessibility. It is important to note 

that accessibility guidelines are not limited to web content but also apply to PDF documents. 

Accessibility is crucial to ensure that everyone, including people with disabilities, can access the 

information they need. In compliance with the guidelines set by the Government of India for Indian 

government websites, it is mandatory for all government websites to be WCAG 2.2 compliant. 

Despite the significance of accessibility, a majority of government documents, both at the central and 

state levels, are not available in an accessible format. The reasons for this are multifaceted and include 

factors such as limited technical knowledge among user departments, a casual approach to document 

publishing, the perceived effort and time required to make documents accessible, and the challenges 

associated with converting old image-based documents into accessible formats. 

This document aims to address these issues by providing education and guidance on creating accessible 

documents using a variety of open-source and proprietary tools. It explores the challenges and efforts 

involved in making documents accessible and serves as a resource for government organizations seeking 

to align with the GIGW (Guidelines for Indian Government websites).  

The reasons for this are summarized below: 

a) Lack of technical knowledge to the user departments 

b) Casual approach in publishing of documents 

c) Efforts and time required in making accessible documents 

d) Old documents published only in image format requires lot of efforts/time and money 

to make them compliant accessible documents 

e) Lack of will of the user organization 

f) Guidelines for Indian Govt. websites (GIGW) is not being fully followed 

The initiative to create this document was sparked by a letter from the MeitY to all the Administrative 

Secretaries of the Government of India, highlighting the need for accessible documents.  

By making documents accessible, we contribute to society and particularly enhance the experience for 

individuals with disabilities who visit government websites to access policies, acts, orders, notifications, 

and other important information. In recent times, numerous government initiatives, such as Skill India, 

Digital India, Make in India, and Start-up India, have been launched, with related content often published 

in PDF format on government websites. Accessible PDF documents enable individuals with disabilities to 

understand and engage with such schemes, thereby facilitating their participation and contribution. 

We believe that once content managers start applying accessibility guidelines to their initial website 

documents, the steps and techniques for making PDF documents accessible will become easier to 

implement. 

Content managers responsible for government websites can refer to this document to ensure that the 

PDF documents published on their respective websites are accessible to individuals with disabilities. 



 
 

 

1. Creating accessible Microsoft Word documents 
To create an accessible PDF from a Word document, it is important that the Word document itself is 

accessible. If not, the converted file will not be accessible either. Editing a PDF later on is much more 

complex than preparing an accessible Word file, which underlines the importance of being thorough 

when creating the base document. 

In order to make the MS Word document accessible, it is important to create a logical reading order and 

structure, with the correct use of elements such as headings, lists and tables. Moreover, the text must 

have sufficient contrast against the background, illustrations and images must have a sufficient 

alternative text etc. In the following steps, we will guide you through the most relevant features, settings 

etc. necessary to make the MS Word document accessible. 

This document contains stepwise guidelines for mouse navigation, as well as keyboard shortcuts, for 

each requirement. As mentioned above, the shortcut keys are based on Microsoft default keyboard 

shortcuts in MS Word and may vary according to the different versions of keyboard layout and display 

language. 

Here is an example of a shortcut – Press Alt + f, i, i, then select Check Accessibility and press Enter. 

Plus (+) requires the user to press and hold the keys before and after simultaneously, while comma (,) 

requires the user to press the following key(s) one by one in the given sequence. In other words, the 

shortcut key above must be applied like this: 

1. Press and hold Alt and f simultaneously, 

2. Release Alt and f, and press sequentially I twice, 

3. Choose Check Accessibility from the list, and 

4. Press Enter 

1.1 Structure and formatting 

A good start is to ensure the document has both a title and a file name that describes the purpose of the 

document. In addition, clear and plain language should be used to write the document. Therefore, it is 

very important to select the correct language of the page, this will also help to develop an accessible PDF 

document when it will be converted from Word to a PDF format. 

1.1.1 WCAG success criteria 
1. Info and relationship (Level A) 

2. Meaningful sequence (Level A) 

3. 1.4.4 Resize text (Level A) 

4. 2.4.2 Page title (Level A) 

5. 3.1.1 Language of page (Level A) 

6. 3.1.2 Language of parts (Level AA) 

1.1.2 Functional performance statements 
Users with following ability impairments can/may be affected: 

1. Usage without vision 

2. Usage with low vision 

3. Usage without vocal capability 

4. Usage with limited cognition 



 
 

 

5. Usage with limited manipulation or strength 

1.1.3 Stepwise guidelines 

The title of the document is very important for all types of users. The title of a document should be easily 

available to assistive technologies such as screen reader. The title should describe the purpose of the 

document without requiring users to read or interpret the contents of the document. File name can be 

provided when creating a document or can also be renamed afterwards. However, it is also 

recommended to provide a title in the properties of the document in addition to file name. This will later 

help in the accessibility of PDF. 

For providing the title of a document in Word, use the following steps. 

Keyboard (title): 

1. Press the Alt + f, i, s, 1 key to add or edit the title of a document. 

Mouse (title): 

1. Select File tab > Info > Under Properties > use Title box to add or edit title of a document. 

1.1.3.1 Language 

Easily understandable language is important for all type of documents. Assistive technologies such as 

screen readers use the language label to select the correct speech synthesis. Therefore, it is also 

important that the document is marked with its correct language. In addition, if a document has parts of 

it such as quotes in another language than the default language of the page, then this should also be 

marked up with the actual language of the text. 

For providing correct language info to a document or part of it in Word, use the following steps. 

Keyboard (language): 

1. Press the Ctrl + a key to select the whole content of a document. 

a. If you want to select language for a part of a document, such as a quote which is in another 

language than the main language of the document. Use Ctrl + Arrow keys to select that 

specific part. 

2. Press Alt + r, u, l keys and choose the actual language to mark the language of a document or 

part of it. 

Mouse (language): 

1. Select Review tab > under Language > select Language > click on Set Proofing Language and 

choose the actual language to mark the language of a document or part of it. 

1.1.3.2 Font and font size 

Font styles are an important aspect of a document which reflect the presentation of the content of a 

document to users. There are no hard and fixed rules about what the best fonts for a document are. 

However, it is important that the given font is easy to read for all users, regardless of their abilities. 

Text size of 12 point or higher is recommended, as it will benefit most users. Users with sight problems 

generally find larger text size easier to read. 



 
 

 

For providing font and font size info to the content of a document or part of it in Word, use the 

following steps. 

Keyboard (font and font size): 

1. Press the Ctrl + d key to open the font dialog box. Other shortcut keys: 

a) For selecting font, use Ctrl + Shift + F 

b) For selecting font, use Ctrl + Shift + P 

2. Select actual font, font style, and/or font size. 

Mouse (font and font size): 

1. Select Home tab > under Font > use Font box to select font and font size. 

1.1.3.3 Headers and footers 

Headers and footers should be formatted using the Header/Footer order, allowing users of assisted 

technologies to distinguish between headers/footers from page content. Some assistive technologies 

may not recognize headers/footers in the Word document; therefore, it is important not to include 

essential information in these areas. It is important that a document formatted with headers and footers 

is accessibly designed in Word so that when the document is converted into PDF format, then the PDF is 

accessible for the users, especially for screen reader users. 

Keyboard (heads and footers): 

1. To create a header in your document, press Alt+N, H. 

2. To create a footer, press Alt+N, O. 

3. Insert the text. 

4. Press Alt+J, H, C to exit the header/footer  

Mouse (heads and footers): 

1. Place the cursor at the top or at the bottom of the document 

2. Select the Insert tab 

3. Click Header or Footer in the Header/Footer group 

4. Select a built-in Header/Footer or choose Edit Header or Edit Footer to add the corresponding 

text. 

1.1.3.4 Moving objects 

The structure of a document also includes movable objects, such as a non-text object like an image or a 

text object such as a text box. If these objects are not structured correctly, then the reading order of the 

document can be affected, especially for users of assistive technologies such as screen reader users. 

Select “Top and Bottom” or “In Line with Text” for the text for text wrapping around objects. This will 

make it easy for screen reader users to follow the structure of the document through the correct reading 

order. 

For changing text wrapping around movable objects in a document in Word, use the following steps. 

Keyboard (wrap text): 

1. Mark the actual object and press Shift + F10. 

2. Select Wrap Text, then select either In Line with Text or Top and Bottom.  



 
 

 

Mouse (wrap text): 

1. Right click on the actual object, select Wrap Text, then click on either In Line with Text or Top 

and Bottom. 

1.1.3.5 Use of Style 

Pre-defined Styles make it easier to define the structure of your document. Structure involves defining 

the different types of content in your document, such as headings, lists, quotes, tables, and columns, 

while making sure that the formatting is consistent, and the document is accessible. 

A style is a set of formatting properties that determine how the content will look, for example font type, 

text size, color, or shading etc. Applying pre-defined styles gives your document a consistent look while 

also providing important information about the content of the document, beyond the visible formatting. 

This information makes a document accessible for assistive technologies, such as screen readers and 

others, who can use styles to navigate through the document if it is formatted using a small set of pre-

defines styles. 

Style(s) can also be edited, and then all the elements in a document marked with this style will undergo 

the same changes. For example, if a style Heading 1 is defined with a font type Arial, text size 16, and 

color blue then all Heading 1 in the document will have the same formatting. 

In Word, there are different types of styles: 

• Character and paragraph styles: Determine the appearance of the text in a document. 

• List styles: Determine the appearance of lists. 

• Table styles: Determine the appearance of tables. 

For applying a style in a document in Word, use the following steps. 

Keyboard (styles): 

1. Place the insertion point in the actual paragraph (paragraph style) or mark text to be formatted 

(character style). 

2. Press Ctrl + Shift + s to open/display the Task Pane for Styles. 

3. Select a style from the list and press Enter. 

4. F6 key can be used for moving between documents, Status bar, Ribbon, and Task pane. 

Mouse (styles): 

1. Place the insertion point in the actual paragraph (paragraph style) or mark text to be formatted 

(character style). 

2. Select Home tab > Styles > use Styles. 

1.2 Headings 
Headings break up text and make content easier to read. When defining a heading, it is important that 

you apply a heading style. Always use heading styles in a logical order and do not skip levels. For example, 

Heading 1 will always be followed by Heading 2 and Heading 2 will be followed by Heading 3 or another 

Heading 2 etc. 

If this is not done, the document will not pass the Accessibility Checker tests. The reason is simple: 

headings are very important, especially for the keyboard users and screen readers users, as they use 



 
 

 

headings to navigate the page by jumping from heading to heading. Without headings, it would be almost 

impossible for these users to navigate a page and to understand the content of the document. 

Correct use of heading styles also allows you to create an automatically generated table of content, 

which makes it possible to jump to the right place in the document. 

As mentioned above, headings should have different levels and those levels must be correctly nested. 

Nesting means using different heading levels in a logical order, in order to indicate which information is 

most important and which block is a subset of another block. 

Furthermore, screen reader users may think they have missed a heading, or they may get confused by 

the order. And remember, when you are writing headings, keep them short, specific to the information 

that follows them, and clear to someone new to the topic. 

If you don’t apply heading styles and instead only change the formatting of the text itself, the heading 

won’t be technically defined as a heading. The appearance may provide a consistent structure visually, 

but the heading will not appear in the navigation or in the table of contents. It will also not be interpreted 

as a heading by assistive technology software. 

1.2.1 WCAG success criteria 
1. Info and Relationships (Level A) 

2. Headings and labels (Level AA) 

3. Name, Role, Value (Level A) 

1.2.2 Functional performance statements 
1. Users without vision 

2. Users with limited vision 

3. Users with deaf blindness 

4. Users with limited manipulation or strength 

5. Users with limited cognition 



 
 

 

1.2.3 Stepwise guidelines 

It is recommended to keep the Navigation Pane open when a user is applying headings or is reading a 

document. It will help you to confirm the correct heading level, the nesting of different headings, and 

navigation back and forth though the headings. 

To view the Navigation pane: 

Keyboard (navigation pane): Press Alt + w, k to open or close Navigation pane. 

Mouse (navigation pane): Select View tab > Show > use Navigation Pane. 

Remember that for a normal paragraph text, use the “Normal” from the Styles list in Word. For 

selecting and applying the correct heading level on a paragraph, use the following steps. 

Keyboard (headings): 

Place the keyboard on a sentence or word that you want to mark as heading. 

1. Press Ctrl + Alt + 1 for Heading level 1. 

2. Press Ctrl + Alt + 2 for Heading level 2. 

3. Press Ctrl + Alt + 3 for Heading level 3. 

4. Press Ctrl + Alt + 4 for Heading level 4. 

5. Press Ctrl + Alt + 5 for Heading level 5. 

6. Press Ctrl + Alt + 6 for Heading level 6. 

7. Press Ctrl + Shift + n to mark the text as a normal paragraph. 

Mouse (headings): 

1. Select Home > Styles > use correct heading 

1.3 Page breaks and text splitting 

Most people consciously or unconsciously use the space bar for a large spacing instead of Tabs. Several 

people use Enter instead of page break etc. White spaces must be avoided as much as possible in a 

document. The reason is that they will be read out as ‘blank blank blank…’ to someone who uses 

assistive technologies, such as screen reader. Instead, use the Word built-in features such as 

indentations, line spacing, and Styles to achieve the desired visual presentation. 

1.3.1 WCAG success criteria 
1. Meaningful Sequence (Level A) 

1.3.2 Functional performance statements 
Users with following ability impairments can/may be affected: 

1. Usage without vision 

2. Usage with low vision 

3. Usage with limited cognition 

1.3.3 Stepwise guidelines 

1.3.3.1 Indentations and inline spacing 

Avoid use of multiple space key for a large spacing in a line or indentation. Use 

Word’s built-in feature “indent” for this purpose. 



 
 

 

Note that indentation and spacing in a line or paragraph are two different ways of spacing. An 

indent or indentation is a space at the beginning of a paragraph. 

However, a spacing can be at the beginning of a paragraph or inside a paragraph or line. 

A quick way for a large spacing at the beginning, inside a line or paragraph is to use the Tab key 

which create an indent of 1/2 inches or 9 spaces at font size 12 points if no specific tab positions 

have been set. Press the Shift + Tab key to decrease spacing. 

Keyboard (indentation): 

1. Place the insertion point at the paragraph you want to indent or add a large spacing. 

2. Press the Ctrl + m key to increase indent or spacing at the beginning of a paragraph. 

3. Press the Ctrl + Shift + m key to decrease indent or spacing at the beginning of a paragraph. 

Mouse (indentation): 

1. Select Home tab > Paragraph > Use Increase Indent or Decrease Indent. 

1.3.3.2 Line and paragraph spacing 

Avoid use of Enter key many times to add spacing between lines and paragraphs. Instead, use Word’s 

built-in feature “Line and Paragraph Spacing” for this purpose. 

Keyboard (line and paragraph spacing): 

1. Place the insertion point at the line or paragraph 

2. Select Home tab, “Line and Paragraph Spacing” from Paragraph, and then “Add Space 

Before Paragraph” if you want to add space before a paragraph. Shortcut keys are as follows: 

a. Add or remove 12 points of space before a paragraph: Ctrl + 0 (Zero) or Alt + h, k, 

select a spacing. 

b. Add Single-spacing: Ctrl + 1 

c. Add 1.5-line spacing: Ctrl + 5 

d. Add Double-spacing: Ctrl + 2 

3. Select Home tab, “Line and Paragraph Spacing” from Paragraph, and then “Add Space After 

Paragraph” if you want to add space before a paragraph. Shortcut keys: 

a. Alt + h, k, a. 

Mouse (line and paragraph spacing): 

1. Select Home tab > Paragraph > “Line and Paragraph Spacing” > Use Add Space Before 

Paragraph or Add Space Before Paragraph. Vice versa if you want to remove spacing before 

or after a paragraph. 

NOTE: It is recommended to use double or 1.5 spacing between lines to improve readability. For long 

text, use left-aligned instead of justified text. 

1.3.3.3 Page break 

Avoid use of Enter key many times to force a page shift. Use Word’s built-in feature “Page Break” for 

this purpose. 



 
 

 

Keyboard (page break): 

1. Place the insertion point at the line or paragraph you want page shift or page break. 

2. Select Insert tab and then select “Page Break” from Pages to add page break. Shortcut keys: 

a. Ctrl + Enter. 

Mouse (page break): 

1. Select Insert tab > Pages > use Page Break 

1.3.3.4 Column shift 

For many users, documents formatted with columns are difficult to read, however some layout 

schemes require this type of formatting. Therefore, it is important that a document formatted with 

columns is accessibly designed in Word so that when the document is converted into PDF format, the 

PDF is accessible for users, especially screen reader users. It is best practice to avoid using column 

split. 

Avoid using the Enter key many times to force a column shift to the beginning of the next column on 

the page. Use Word’s built-in feature “Column Break” for this purpose. 

Keyboard (column shift): 

1) Place the insertion point at the line or paragraph you want column shift or column break. 

2) Select Layout tab, click “Breaks” from Page Setup, and then select “Column” to insert a 

column break. Shortcut key: 

a) Ctrl + Shift + Enter 

3) A column break is inserted. 

4) Tip: Click Home > Show/Hide (Paragraph mark) to see it. Shortcut key: 

a) Ctrl + ( 

Mouse (column shift): 

1) Select Layout tab > Page Setup > click Breaks > choose Column. 

1.4 Lists 

Use the List function to create bulleted and numbered lists. Most screen readers offer functionality 

for navigating directly inside lists. The reader will also know how many items are in the list. In 

addition to that, a screen reader also provides information regarding where the lists start and ends, 

and what list item the user is on. If the proper list function is not used, then it would be hard for the 

screen reader to properly read the lists. Therefore, it is important to use Word’s built-in list feature 

in Home tab. 

1.4.1 WCAG success criteria 

1. Info and relationships (Level A) (WCAG 1.3.1) 
2. Name, Role, Value (Level AA) (WCAG 4.1.2) 

1.4.2 Functional performance statements 

Users with following ability impairments can/may be affected: 

1. Usage without vision 
2. Usage with low vision 
3. Usage with limited cognition 



 
 

 

1.4.3 Stepwise guidelines 

Keyboard (list): 

1. Select the text you want to mark as a list 

2. Press Alt + h to go to the home tab: 

a) For a bulleted list – u. 

b) For a numbered list – n. 

c) For a multilevel list – m. 

3. Select the appropriate list style from the list. 
Mouse (list): 

1. Select Home > Paragraph > choose bullet, numbered, or multilevel list. 

1.5 Images and illustrations (non-text content) 

Images and illustrations are very important for many user groups. However, images that convey a 

meaning must have an alternative text that describes the purpose of the image. This allows users 

who cannot see the image in the document to comprehend its content, nonetheless. 

Decorative Images: Images that do not convey any meaning or content are decorative images. 

These images should not have an alternative text, but rather be marked as decorative. 

Groups of images: If multiple images convey a single piece of information, the text alternative for 

one image should convey the information for the entire group. 

Linked Image/Functional image: Images used to provide important functions such as navigations 

are linked or functional images. Functional Images should have the alternative text as to describe 

the function of the image. 

Complex images: Complex images convey a large amount of information that cannot be 

structured into a short and concise alt text. They should have an alternative text that describes 

the data and a longdesc or a longer alternative to detail the complex image. 

Image of text: Image of text is, as the name suggests, an image of text. This should be avoided, if 

possible, but if used, the alternative text should contain whatever is written on the image. 

Advanced Images: Form Image buttons: A form image button is a visual representation inside a 

form. The alternative text should describe what the button will do when selected. 

Image maps: An image map is a map of images that together make up a greater picture. In these 

cases, the container of images should have an alt attribute which describes the whole image and 

every image inside the map should have a descriptive alt attribute. 

Logos: Logos are a company's branding on a web page or document. Logos should have an 

alternative text that identifies the company, for example the company name. 

To decide in which category, a particular image or illustration fits in, refer to the alt Decision Tree 

(W3C) 

NOTE: 

We recommend to: 

1. Be accurate in representing content and function. 
2. Add image descriptions to essential images and charts. 
3. Mark non-essential visual elements as decorative 
4. Choose in line wrapping for essential images 
5. Avoid redundancy. 

https://www.w3.org/WAI/tutorials/images/decision-tree/
https://www.w3.org/WAI/tutorials/images/decision-tree/
https://www.w3.org/WAI/tutorials/images/decision-tree/


 
 

 

6. Avoid including phrases like "image of ..." or "graphic of ...". This is redundant 

since screen readers already announce "graphic" along with the alternative 

text. 

1.5.1 WCAG success criteria 

1. Non-text Content (Level A) 
2. Image of Text (Level AA) 
3. 1.4.1 Use of colour (Level A) 
4. 1.4.3 Contrast (Level AA) 

1.5.2 Functional performance statements 

Users with following ability impairments can/may be affected: 

1. Usage without vision 
2. Usage with low vision 
3. Usage with limited cognition 

1.5.3 Stepwise guidelines 
Keyboard (non-text content): 

1. Select the image you want to provide alternative text 
2. Press Shift+F10 
3. Choose Edit Alt Text. 
4. Add appropriate alt-text that describe the purpose of the content of the image. 

a. If the image is a decorative image – Check the checkbox Mark as decorative. 

Mouse (non-text content): 

1. Select the image you want to provide an alternative text to 
2. Right click on it and choose Edit Alt Text. 
3. Add appropriate alt-text that describe the purpose of the content of the image. 

a. If the image is a decorative image – Check the checkbox Mark as decorative. 

1.6 Links 

Links should have a descriptive link text, so that it is easy to understand the destination of the links 

included in the document. Either the link text alone, or the link text together with the text around it, 

must clearly describe the purpose and/or destination of the link. Many users rely on link text alone. 

The link text should therefore be understandable out of context. It should also be easy for the user 

to see the links in the document. This means that links must be marked using more than just color. 

For example, the link text can be underlined, or an icon can be associated with the link - but often 

in combination with  color. 

1.6.1 WCAG success criteria 

1. 1.4.1 Use of Colour 
2. 2.4.4 Link Purpose (in Context) (Level A) 

1.6.2 Functional performance statements 

Users with following ability impairments can/may be affected: 

1. Usage without vision 
2. Usage with low vision 
3. Usage with deaf blindness 
4. Usage with limited cognition 
5. Usage with limited manipulation or strength 

https://www.uutilsynet.no/regelverk/lenker/214#beskrivelse


 
 

 

1.6.3 Stepwise guidelines 

Keyboard (Links): 

1. Select the link text or linked image you want to make a link 
2. Press Ctrl + k 
3. Write a link-address in the Address text field. 
4. Write a descriptive link text in the Text to Display text field, then press OK button. 

Mouse (Links) 

1. Select the link text or linked image you want to make a link 
2. Right click, click on option Link, and then Insert Link 

3. Write a link-address in the Address text field. 
4. Write a descriptive link text in the Text to Display text field, then click on OK button. 

1.7 Tables 

Tables can be challenging for the people who use assistive technology, such as screen reader users. 

Proper use of tables is crucial for the information to be interpreted correctly by assistive 

technology’s users. The more complex the table is, for example, a table with merged or split cells 

and nested tables, empty rows and columns, the harder it is to make it accessible. Therefore, you 

should always consider first if it is necessary to present the information as a table. If the answer 

to that question is yes, you must make sure the table is created in the correct way and seek to 

make the table as simple as possible. 

It is recommended to use Word built-in table feature in the insert tab in order to create a table 

in your work. Moreover, the following information must be provided  appropriately: 

1. Table title 
2. Table header cells 

1.7.1 WCAG success criteria 

1. Info and relationship (Level A) 
2. Parsing (Level A) 
3. Name, Role, Value (Level A) 

1.7.2 Functional performance statements 

Users with following ability impairments can/may be affected: 

1. Usage without vision 
2. Usage with low vision 
3. Usage with cognitive limitations 
4. Usage with deaf blindness 
5. Usage with limited manipulation or strength 

1.7.3 Stepwise guidelines 

Keyboard (Tables) 

1. Press Alt + n, t to insert table 
2. Select number of rows and column and press enter. 
3. Press Alt + jt, a to check header row. 
4. Press Alt + jl, o to open table properties. 
5. Navigate to Alt Text tab and add a descriptive title in the Title text field. 

Mouse (Tables) 

1. Select Insert > Tables > use Table 
2. Select number of rows and column and press enter. 
3. Select Table Design > Table Style Option > check Header Row 



 
 

 

4. Right click on table, select Table Properties, and then navigate to Alt Text tab and add a 

descriptive title in the Title text field. 

1.8 Accessibility Check for Word 

Microsoft provides an Accessibility Checker tool in Word, which is an essential tool for ensuring 

the accessibility of a document. The Accessibility Checker does not check for all access issues, 

but it can help the author discover any obvious accessibility issues that can be fixed. Hence, it is 

recommended running the Accessibility Checker and fix the issues (if any). 

The Accessibility Checker distinguishes between three types of feedback. Microsoft defined them 

as Accessibility Checker rules3 and describes them as follows: 

Errors: Content that makes the document difficult or impossible to read and understand 

for people with disabilities. 

Warning: Content that in most (but not all) cases makes the document difficult to understand 

for people with disabilities. 

Tips: Content that people with disabilities can understand, but that could be 

presented in a different way to improve the user’s experience. 

1.8.1 Stepwise guidelines to run the Accessibility Checker 

To run the accessibility Checker, use the following steps: 

Keyboard (Accessibility Checker): 

1. Press Alt + f, i, i, then select Check Accessibility and press Enter. 
2. The Accessibility Checker pane will open, and results will display in task pane Accessibility. 
3. Select an issue to display additional information and the instruction to correct the issue. 

Mouse (Accessibility Checker): 

1. Select Accessibility from the Status Bar; or 
2. Select File table > Info > select Check for Issues > use Check Accessibility 

3. The Accessibility Checker pane will open, and results will display in task pane Accessibility. 
4. Select an issue to display additional information and instruction to correct the error. 

2. Converting from Word to PDF 
In order to create an accessible PDF file, you must:   

1. Prepare a well-structured document with image descriptions in Microsoft Word.  

2. Use the Accessibility Checker and fix errors if any  

3. Use at least one assistive technology such as the open-source screen reader NVDA to test 

the reading order and identify any remaining accessibility barriers   

4. When your accessible Word document is ready, save it as PDF.  

To convert documents from Word to PDF, be sure to use the correct settings. There are several ways 

to maintain these settings. Adobe PDF Maker and Word’s built-in “Save As” are examples of methods 

that work correctly. If you use Word’s “Save As” feature, it is important that the conversion preserves 

the properties of the original document.  

To make sure Word converts correctly:  



 
 

 

1. select “Save As”  

2. select PDF file format  

3. click the “Options” button  

4. select the “Create bookmarks using headings” option  

5. select “Document structure tags for accessibility”  

6. Uncheck “Convert Comments” if you do not want to keep comments in the PDF file.  

When you create the PDF correctly, all content objects are assigned a so-called “tag” that defines - 

either alone or together with a role assignment - how screen readers will interpret the objects in the 

document. This allows screen reader users to perceive headings or find their way around a table.   

You can also use the ‘print to PDF’ command. However, this doesn’t preserve the accessibility that 

well. It is therefore recommended to avoid this function. 

  



 
 

 

3. Creating Accessible LibreOffice documents 
 

Creating accessible content using LibreOffice not only helps people with disabilities access, navigate 

and understand your content, but there are many benefits for everyone else too. 

Good accessibility means better use of your content in many other technologies, assistive or 

otherwise. This page outlines a list of actions that accumulatively contribute to accessibility. 

 

3.1 How to add title to Libre Document 

1. Open the original in LibreOffice 

2. Click File from menu and select Properties 

3. Click Description and Enter the Title 

 

 
 

3.2 How to save a tagged PDF 
Saving a tagged PDF using LibreOffice (PC and Mac) 

1. Open the original in LibreOffice 

2. Click File from the menu and select Export as PDF. 

3. In the PDF Options dialog box, make sure the Tagged PDF (add document structure) and 

the Export bookmarks boxes are selected. 

4. Click Export. 

 

3.3 How to add headings 

Adding headings in LibreOffice Writer (PC and Mac) 

Turning text into headings. 

1. Open the original in LibreOffice Writer. 

2. Select the text that should become a heading. 

3. In the Formatting bar, open the Apply Paragraph Style dropdown and select the appropriate 

heading level. If you don’t see the heading level you are looking for, click More options. 

4. Repeat this for all the text that should become headings. 



 
 

 

 

 

3.4 Styling headings in LibreOffice Writer 

Customizing the visual appearance of a heading style. 

1. Open the Apply Paragraph Style dropdown. Click the arrow next to the heading style of which 

you want to change the visual appearance. 

2. Click Edit Style from the menu. 

3. Make any formatting changes that you would like to make (e.g., Font, font size, etc) in 

the Font and Font Effects tabs and click OK. All text which has that heading applied will 

automatically be updated. 

4. Save the document. 

 

 

3.5 How to add alternative descriptions to images in a document 

Adding an image description in LibreOffice Writer (PC) 

1. Open the original in LibreOffice Writer. 

2. Double click the image. The Image dialog box shows up. 

3. Click the Options tab in the Image dialog box. 

https://wiki.documentfoundation.org/File:LibreOfficeWriter-Headings.png
https://wiki.documentfoundation.org/File:LibreOfficeWriter-Heading-Styles.png


 
 

 

 

4. Enter a brief description for the image in the Name field. 

 

Adding an image description in LibreOffice Writer (Mac) 

1. Open the original in LibreOffice Writer. 

2. Double click the image. The Image dialog box shows up. 

3. Click the Options tab in the Image dialog box. 

 

4. Enter a brief description for the image in the Name field. 

 

3.6 How to add headers to a table 

Adding headers to a table in LibreOffice Writer (PC) 

1. Open the original in LibreOffice Writer. 

2. Ensure the text in the first-row functions as a title and identifies what each column is for. E.g.: 

Week, Topic, Date and so on. 

3. Right-click the table and select Table Properties. Or select Table Properties from the bottom 

or top menu. The Table Format dialog box shows up. 

4. In the Table Format dialog box, select the Text Flow tab. Make sure the Repeat heading check 

box is selected and that at least the first row is filled out. 

https://wiki.documentfoundation.org/File:LibreOfficeWriter-ImageOptions-PC.png
https://wiki.documentfoundation.org/File:LibreOfficeWriter-ImageOptions-Mac.png


 
 

 

 

5. Repeat these steps for tables in the document. Save the document. 

 

Adding headers to a table in LibreOffice Writer (Mac) 

1. Open the original in LibreOffice Writer. 

2. Ensure the text in the first-row functions as a title and identifies what each column is for. E.g.: 

Week, Topic, Date and so on. 

3. Right-click the table and select Table Properties. Or select Table Properties from the bottom 

or top menu. The Table Format dialog box shows up. 

4. In the Table Format dialog box, select the Text Flow tab. Make sure the Repeat heading check 

box is selected and that at least the first row is filled out. 

 

5. Repeat these steps for tables in the document. Save the document. 

 

3.7 How to set a language 

Setting the document language in LibreOffice Writer (PC) 

1. Open the original in LibreOffice Writer. 

2. Determine the main language of the text. When a lot of text is underlined with red squiggly 

lines, this is often an indication that the language isn’t set correctly. 

3. Set the correct document language by clicking on Tools > Language > For all Text > More…. 

The Options - Language Settings - Languages dialog box shows up. 

https://wiki.documentfoundation.org/File:LibreOfficeWriter-TableHeaders-PC.png
https://wiki.documentfoundation.org/File:LibreOfficeWriter-TableHeaders-Mac.png


 
 

 

 

4. Under Default Languages for Documents, select the correct document language from the 

dropdown. If you check for the current document only, your choice will only apply to the 

current document. 

5. Click OK and save the document. 

 

 

Setting the document language in LibreOffice Writer (Mac) 

1. Open the original in LibreOffice Writer. 

2. Determine the main language of the text. When a lot of text is underlined with red squiggly 

lines, this is often an indication that the language isn’t set correctly. 

3. Set the correct document language by clicking on Tools > Language > For all Text > More…. 

The Options - Language Settings - Languages dialog box shows up. 

 

4. Under Default Languages for Documents, select the correct document language from the 

dropdown. If you check for the current document only, your choice will only apply to the 

current document. 

5. Click OK and save the document. 

https://wiki.documentfoundation.org/File:LibreOfficeWriter-ToolsMenuLanguage-PC.png
https://wiki.documentfoundation.org/File:LibreOfficeWriter-LanguagesMore-PC.png
https://wiki.documentfoundation.org/File:LibreOfficeWriter-ToolsMenuLanguage-Mac.png


 
 

 

 

 

Choosing a language for selected text in LibreOffice Writer (PC) 

Text that is still underlined with red squiggly lines or paragraphs in a different language need their 

language set separately. 

1. Select all the text in specific text boxes that need changing. 

2. Right-click the selected text and choose Character… from the menu. The Character dialog box 

shows up. 

3. On the Font tab, select the correct language for the selected text and click OK. 

4. Repeat these steps for all the text that needs changing. 

5. Save the document. 

 

 

Choosing a language for selected text in LibreOffice Writer (Mac) 

Text that is still underlined with red squiggly lines or paragraphs in a different language need their 

language set separately. 

https://wiki.documentfoundation.org/File:LibreOfficeWriter-LanguagesMore-Mac.png
https://wiki.documentfoundation.org/File:LibreOfficeWriter-Character-PC.png


 
 

 

1. Click on the View tab and select Outline. Select the text from all the slides that need 

changing. 

2. Right-click and choose Character… from the menu. The Character dialog box shows up. 

3. On the Font tab, select the correct language for the selected text and click OK. 

4. Repeat these steps for all the text that needs changing. 

5. Save the document. 

 

3.8 How to create accessible list in LibreOffice 

1. Right-click a paragraph/ list 

2. choose List - Add to List. 

3. On Bullets and Numbering bar, click Add to List icon. 

 

 

https://wiki.documentfoundation.org/File:LibreOfficeWriter-Character-Mac.png


On behalf of the National Informatics Centre (NIC), we extend our appreciation for your commitment 

to creating accessible content using M.S. Word & LibreOffice. Accessibility is a core value at NIC, and 

your efforts contribute to a more inclusive digital environment. As you continue to champion 

accessibility, know that NIC stands ready to support you. Thank you for joining hands with NIC in our 

shared mission of promoting digital inclusivity. 

Resources and Reference Links: 

1. AbilityNet - Creating Accessible Documents

2. European Blind Union - Making Information Accessible for All

3. Microsoft Support - Create Accessible Office Documents

4. LibreOffice Accessibility

5. W3C - Web Content Accessibility Guidelines (WCAG) 2.0 Techniques

6. WebAIM - Techniques for Accessible Word Documents

7. Adobe - Create and Verify PDF Accessibility

https://abilitynet.org.uk/factsheets/creating-accessible-documents-0
https://www.euroblind.org/publications-and-resources/making-information-accessible-all
https://support.microsoft.com/en-us/office/create-accessible-office-documents-868ecfcd-4f00-4224-b881-a65537a7c155
https://www.libreoffice.org/get-help/accessibility/
http://www.w3.org/TR/2014/NOTE-WCAG20-TECHS-20140408/pdf.html
https://webaim.org/techniques/word/
https://helpx.adobe.com/in/acrobat/using/create-verify-pdf-accessibility.html
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